buuka/default.nix

26 lines
867 B
Nix

{ mkDerivation, aeson, base, bytestring, conduit, conduit-extra
, containers, deriving-compat, exceptions, filepath, hashable
, hashids, hedgehog, hedgehog-corpus, lens, lib, mtl
, optparse-applicative, regex-tdfa, sqlite-simple, tasty
, tasty-hedgehog, tasty-hunit, text, transformers, unliftio, vector
, yaml
}:
mkDerivation {
pname = "buuka";
version = "0.1.0.0";
src = ./.;
isLibrary = true;
isExecutable = true;
libraryHaskellDepends = [
aeson base bytestring conduit conduit-extra containers exceptions
filepath hashable hashids lens mtl regex-tdfa sqlite-simple text
transformers unliftio vector yaml
];
executableHaskellDepends = [ base optparse-applicative unliftio ];
testHaskellDepends = [
aeson base deriving-compat hedgehog hedgehog-corpus tasty
tasty-hedgehog tasty-hunit text
];
license = lib.licenses.bsd3;
}