hledger-time/default.nix

23 lines
610 B
Nix

{ mkDerivation, attoparsec, base, bytestring, conduit, hedgehog
, hedgehog-corpus, hspec, hspec-hedgehog, lib, optparse-applicative
, temporary, text, time
}:
mkDerivation {
pname = "hledger-time";
version = "0.1.0.0";
src = ./.;
isLibrary = true;
isExecutable = true;
libraryHaskellDepends = [
attoparsec base bytestring conduit optparse-applicative temporary
text time
];
executableHaskellDepends = [ base ];
testHaskellDepends = [
base bytestring conduit hedgehog hedgehog-corpus hspec
hspec-hedgehog text time
];
license = "unknown";
mainProgram = "hledger-time";
}