nixos-gitit/gitit/cabal.nix

41 lines
1.7 KiB
Nix

{ mkDerivation, aeson, base, base64-bytestring, blaze-html
, bytestring, ConfigFile, containers, directory, doctemplates, feed
, fetchgit, filepath, filestore, ghc, ghc-paths, happstack-server
, hoauth2, hslogger, HStringTemplate, HTTP, http-client-tls
, http-conduit, json, lib, mtl, network, network-bsd, network-uri
, old-locale, old-time, pandoc, pandoc-types, parsec, pretty
, process, random, recaptcha, safe, SHA, skylighting, split, syb
, tagsoup, temporary, text, time, uri-bytestring, url, utf8-string
, uuid, xhtml, xml, xml-conduit, xml-types, xss-sanitize, zlib
}:
mkDerivation {
pname = "gitit";
version = "0.15.1.0";
src = fetchgit {
url = "https://github.com/jgm/gitit";
sha256 = "0rzjgi6q338n6cv74438q81v322x2wjrpa7zdvp47z6hrilwpqaa";
rev = "11a18b034cc49ddaca652ac745fd308405a1fdad";
fetchSubmodules = true;
};
isLibrary = true;
isExecutable = true;
enableSeparateDataOutput = true;
libraryHaskellDepends = [
aeson base base64-bytestring blaze-html bytestring ConfigFile
containers directory doctemplates feed filepath filestore ghc
ghc-paths happstack-server hoauth2 hslogger HStringTemplate HTTP
http-client-tls http-conduit json mtl network network-bsd
network-uri old-locale old-time pandoc pandoc-types parsec pretty
process random recaptcha safe SHA skylighting split syb tagsoup
temporary text time uri-bytestring url utf8-string uuid xhtml xml
xml-conduit xml-types xss-sanitize zlib
];
executableHaskellDepends = [
base bytestring directory filepath hslogger HTTP mtl network
network-uri syb text url utf8-string
];
description = "Wiki using happstack, git or darcs, and pandoc";
license = "GPL";
}